ハニカムウエアのブログ

読者です 読者をやめる 読者になる 読者になる

ハニカムウエアのブログ

システム開発、セキュリティ対策についての記事を書いています。

Java コンパイラー・レベルが、インストールされている Java プロジェクト・ファセットのバージョンと一致しません というエラーが出た場合

先日eclipseでビルドを行った際に下記のエラーが表示されました。

「型 Java コンパイラー・レベルが、インストールされている Java プロジェクト・ファセットのバージョンと一致しません。」

原因はビルドしたプロジェクトの、Javaコンパイラーのバージョンとプロジェクト・ファセットで選択されているJavaのバージョンが異なっていることでした。

エンジニアによるエンジニアのためのサイト始まる!!【teratail】

というわけで下記の操作でエラーは解消できました。

 

①下の画像で言うと左上のパッケージ・エクスプローラーでプロジェクトを選択

f:id:honeycomware_inc:20161124230933j:plain

②プロジェクトを右クリック→メニューから"プロパティー"を選んでクリック。

→左のメニューからJavaコンパイラーを選択してJavaのバージョンを確認(画像では1.8になっていることを確認できます)

f:id:honeycomware_inc:20161124231007j:plain

③次にそのまま左のメニューからプロジェクト・ファセットを選択してそこからJavaの表示を選択して右クリック。→バージョンの変更をクリック

f:id:honeycomware_inc:20161124231031j:plain

④下の画像のようにバージョンの変更画面が出るので、バージョンを先ほどJavaコンパイラーで表示されていたバージョンと合うものを選択します。

f:id:honeycomware_inc:20161124231109j:plain

⑤選択したらOKボタンを押します。

f:id:honeycomware_inc:20161124231123j:plain

⑥右下の適用を押す。

f:id:honeycomware_inc:20161124231133j:plain

⑦最後にOKボタンを押して終了です。

f:id:honeycomware_inc:20161124231145j:plain

 

以上です!

エンジニアによるエンジニアのためのサイト始まる!!【teratail】

もしこれで解決できなかったときはコメントください…汗

 ーーーーーーーーーーーーーーーーーーーーーーーーーー

弊社ホームページもぜひご覧ください。

 f:id:honeycomware_inc:20170106130819j:plain